User Tools

Site Tools


en:requirements

Requirements

To install OCAx you need access to a web server with:

  • A linux server
  • PHP5 5.3 or higher is required.
  • MySQL (MariaDB not tested but we'd like to know)

Required PHP extensions. These are common extension but check with your provider.

  • $_SERVER variable
  • Reflection extension
  • PCRE extension
  • SPL extension
  • DOM extension
  • PDO extension
  • PDO MySQL extension
  • Mcrypt extension
  • crypt() CRYPT_BLOWFISH option
  • GD extension with FreeType support or ImageMagick extension with PNG support
  • Ctype extension
  • Fileinfo extension
  • Zip extension
en/requirements.txt · Last modified: 2015/08/05 14:52 by tuttle